Performance Degradation in Provisioning Tasks Window

Incident Report for CVaaS

Resolved

The fix has been successfully deployed to all regions. Customers will have to reload the UI for the changes to take effect.
Posted Mar 12, 2026 - 21:57 UTC

Monitoring

A fix is currently being deployed.
Posted Mar 12, 2026 - 21:36 UTC

Identified

We are investigating a performance degradation when when loading the Tasks windows within Provisioning. For customers with a large number of historical tasks, page load times have increased significantly. This will significantly impact core provisioning workflows.

We are aware of the underlying cause and are actively working on a fix.
Posted Mar 12, 2026 - 15:33 UTC
This incident affected: us-central1-a (Network Provisioning), us-central1-c (Network Provisioning), euwest-2 (Network Provisioning), apnortheast-1 (Network Provisioning), ausoutheast-1 (Network Provisioning), na-northeast1-b (Network Provisioning), uk-1 (Network Provisioning), us-central1-b (Network Provisioning), india-1 (Network Provisioning), and us-4 (Network Provisioning).