High Device Streaming Latency experienced on the Platform

Incident Report for CVaaS

Resolved

This incident has been resolved.
Posted Jun 11, 2025 - 16:42 UTC

Monitoring

Streaming latency stabilized. We are still monitoring the issue.
Posted Jun 11, 2025 - 14:17 UTC

Investigating

We are currently experiencing high device streaming latency on this affected cluster.

Some impact may be user visible, such as:
- There is no data loss, however due to delay in processing streamed device data, some events such as "Device stopped streaming" or "Streaming Latency Breached Threshold" may fire. Please note that there is no data loss and all data will be processed with some delay during the impact window.
- There may be some stale data, or sporadic timeouts viewing parts of the UI.

We are currently investigating the issue and working on mitigation. Thank you for your patience.
Posted Jun 11, 2025 - 13:32 UTC
This incident affected: euwest-2 (Core Platform).