High Device Streaming Latency experienced on the Platform

Incident Report for CVaaS

Resolved

This incident is resolved
Posted Sep 11, 2025 - 23:17 UTC

Monitoring

We're currently monitoring the cluster.
Posted Sep 11, 2025 - 19:33 UTC

Investigating

We are currently experiencing high device streaming latency on this affected cluster.

Some impact may be user visible, such as:
- A delay in processing streamed device data. Some events such as "Device stopped streaming" or "Streaming Latency Breached Threshold" may fire as a result of this. In this case, the device updates are behind schedule and will be processed with some delay during the impact window.
- There may be some stale data, or sporadic timeouts viewing parts of the UI.
- Some provisioning features may be delayed or timeout due to the high latency.

The latency is due to a database operation that is currently in progress. Thank you for your patience.
Posted Sep 11, 2025 - 18:00 UTC
This incident affected: us-central1-b (Core Platform).