High Device Streaming Latency experienced on the Platform

Incident Report for CVaaS

Resolved

This incident has been resolved.
Posted Sep 11, 2025 - 00:32 UTC

Identified

We are currently experiencing high device streaming latency on this affected cluster.

Some impact may be user visible, such as:
- A delay in processing streamed device data. Some events such as "Device stopped streaming" or "Streaming Latency Breached Threshold" may fire as a result of this. In this case, the device updates are behind schedule and will be processed with some delay during the impact window.
- There may be some stale data, or sporadic timeouts viewing parts of the UI.
- Some provisioning features may be delayed or timeout due to the high latency.

We are currently investigating the issue and working on mitigation. Thank you for your patience.
Posted Sep 10, 2025 - 23:18 UTC
This incident affected: us-central1-b (Core Platform).